Biçemleri ve şablonları kullanmak

Libreoffice Türkiye Vikisi sitesinden
Atla: kullan, ara


Başlangıç Kılavuzu

Bölüm 3Biçemleri ve Şablonları Kullanmak


Konu başlıkları

Telif Hakkı

Bu belgenin telif hakkı (Copyright © 2011) aşağıda listelenmiş katkıcılara aittir. GNU Genel Kamu Lisansı sürüm 3 veya sonrası (http://www.gnu.org/licenses/gpl.html) veya Creative Commons Attribution Lisansı sürüm 3.0 veya sonrası(http://creativecommons.org/licenses/by/3.0/) maddeleri altında dağıtabilir ve/veya değişiklik yapabilirsiniz.

Bu kılavuzdaki tüm ticari markalar yasal sahiplerine aittir.

Katkıcılar

Ron Faile Jr.

Geri Bildirim

Lütfen bu belge hakkındaki yorum ve önerilerinizi aşağıdaki adrese bildirin: documentation@libreoffice.org

Teşekkür

Bu kitap OpenOffice.org 3.3 Başlangıç Kılavuzunun 3'üncü bölümü temel alınarak hazırlanmıştır. Kitaba katkı verenler:

Jean Hollis WeberMichele ZarriAgnes BelzunceDaniel CarreraPeter Hillier-BrookPeter KupferGary SchnablJanet Swisher

Yayım Tarihi ve Yazılım Sürümü

Tarih: 19 June 2010Sürüm: LibreOffice 3.3.

Mac Kullanıcıları İçin Not

Bazı tuş kullanımları ve menü ögeleri Mac'de Windows ve Linux'tan farklıdır. Bu bölümdeki komutlar için aşağıdaki tabloda bazı genel yerine kullanımlar verilmiştir. Detaylı bir liste için Yardım uygulamasına bakınız.


Windows/Linux Mac Karşılığı Sonuç
Araçlar → Seçenekler menü seçimi LibreOffice - Tercihler Ayar seçeneklerine bağlanır
Sağ-tık Ctrl+Tık Bir içerik menüsü açar
*


z (Komut) Diğer tuşlarla kullanılır
F5 Shift+z+F5 Gezgini açar
F11 z+T Biçem ve Biçimlendirme penceresini açar

İçindekiler

Telif Hakkı2

Mac Kullanıcıları İçin Not2

İçindekiler3

Şablon nedir?4

Biçemler nelerdir?4

Biçemleri uygulamak5

Biçemler ve Biçimlendirme penceresini kullanmak5

Doldurma Biçim Kipini kullanmak6

Biçemi Uygula listesini kullanmak7

Klavye kısayollarını kullanmak7

Biçemleri değiştirmek7

Biçem penceresini kullanarak bir biçemi değiştirmek8

Bir seçimden bir biçemi güncellemek8

Otomatik Güncelle'yi kullanmak8

Bir belge veya şablondan biçemleri güncellemek8

Yeni (özel) biçemler oluşturmak9

Biçem iletişim penceresini kullanarak yeni bir biçem oluşturmak9

Bir seçimden yeni bir biçem oluşturmak9

Yeni bir biçem oluşturmak için Sürüklemek ve Bırakmak10

Biçemleri kopyalamak ve taşımak10

Şablon Yönetimim penceresini kullanarak10

Bir şablon veya belgeden biçemleri yüklemek11

Biçemleri silmek12

Bir belge oluşturmak için şablon kullanmak12

Şablon oluşturmak13

Bir belgeden şablon oluşturmak13

Sihirbaz kullanarak bir şablon oluşturmak14

Bir şablonu düzenlemek15

Değiştirilen bir şablondan bir belgeyi güncellemek15

Eklenti yöneticisini kullanarak şablonlar eklemek16

Varsayılan şablonu ayarlamak17

Özel bir şablonu varsayılan olarak ayarlamak17

Varsayılan şablona sıfırlamak18

Farklı bir şablonla bir belgeyi birleştirmek 18

Şablonları yönetmek19

Bir şablon dizini oluşturmak19

Bir şablon dizinini silmek19

Bir şablonu taşımak19

Bir şablonu silmek19

Bir şablonu içe aktarmak20

Bir şablonu dışa aktarmak20

Biçem kullanma örnekleri20

Bir belge için farklı bir ilk sayfa belirlemek20

Bir belgeyi bölümlere ayırmak20

Bir belgedeki sayfa yönlendirmesini değiştirmek21

Sağ ve sol sayfalarda farklı üst bilgiler21

Sayfa sonlandırmasını otomatik olarak denetlemek21

Bir otomatik içindekiler tablosu derlemek21

Biçemlerin sırasını tanımlamak21= Şablon nedir? = Şablon başka belgeler oluşturmak için kullandığınız bir modeldir. Örneğin, ilk sayfasında sizin şirketinizin logosu olan iş raporları için bir şablon oluşturabilirsiniz. Bu şablondan ilk sayfalarında şirketinizin logosunun olduğu yeni belgeler oluşturabilirsiniz.

Şablonlar normal belgelerin içerdiği metin, grafik, biçem seti ve ölçü birimleri, dil, varsayılan yazıcı, araç çubuğu ve menü özelleştirmesi gibi kullanıcı tanımlı kurulum ayarları içermezler.

LibreOffice'deki tüm belgeler şablon temellidir. Herhangi bir belge türü (metin, hesap tablosu, çizim, sunum) için belirli bir şablon oluşturabilirsiniz. Yeni bir belge başlattığınızda bir şablon belirlemezseniz belge kendi türünün varsayılan şablonu üzerine temellendirilir. Eğer bir varsayılan şablon belirlememişseniz LibreOffice o belge türünün kurulum esnasında yüklenen boş şablonunu kullanır. Daha fazla bilgi için sayfa 18'daki “Varsayılan şablonu ayarlamak” konusuna bakın.

Biçemler nelerdir?

Bir biçem belgenizdeki seçilen sayfaya, metne, çerçeveye ve diğer ögelere çabucak görünümlerini değiştirmek için uygulayabileceğiniz biçimlendirme kümesidir. Bir biçemi uyguladığınızda aynı anda tüm biçimlendirme grubunu uygularsınız.

Birçok insan belgelerindeki paragrafları, kelimeleri, tabloları, sayfa düzenlerini ve diğer parçaları biçemlere dikkat etmeksizin elle biçimlendirirler. Belgeleri fiziksel özelliklere göre yazmaya alışıklardır. Örneğin, yazı tipi, yazı boyutu ve koyu veya italik gibi biçimlendirmeleri belirleyebilirsiniz.

Biçemler mantıksal niteliklerdir. Biçemleri kullanmak demek “yazı tipi boyutu 14, Liberation Sans, koyu, ortalamış” demeye son vermek ve “Başlık” demeye başlamaktır çünkü bu özellikleri içeren “Başlık” biçemini belirlemişsinizdir. Diğer bir deyişle biçemler metnin (veya sayfa veya diğer öge) görümünden kendisine vurgu geçişi yaparlar.

Biçemler bir belgedeki tutarlılığı artırır. Ayrıca büyük biçimlendirme değişikliklerini kolayca yaparlar. Örneğin, tüm paragrafların girintisini değiştirmeye veya tüm başlıkların yazı tipini değiştirmeye karar verebilirsiniz. Belge boyunca bu basit iş engelleyici olabilir. Biçemler bu işi kolaylaştırır.

Ayrıca, biçemler siz farkında olmasanız bile LibreOffice tarafından birçok süreç için kullanılır. Örneğin, Writer bir tablonun içeriğini derlerken başlık biçemlerine (veya belirleyeceğiniz diğer biçemlere) bağlıdır. Biçem kullanımının bazı genel örnekleri sayfa 21'de “Biçem kullanma örnekleri” konusunda verilmiştir.

LibreOffice aşağıdaki biçem türlerini desteklemektedir:

  • Sayfa biçemleri yazdırma alanını, üst bilgi ve alt bilgileri, sınırlar ve arkaplanı kapsar. Calc'da sayfa biçemleri yazdırma sırasını da kapsar.
  • Paragraf biçemleri paragraf görünümünün metin hizalaması, sekme durakları, satır boşluğu ve sınırlar gibi tüm görünüşlerini kontrol eder ve karakter biçimlendirmeyi de kapsayabilir.
  • Karakter biçemleri bir paragraf içinde seçilen metni yazı tipi ve metin boyutu veya koyu veya italik gibi biçimleri etkiler.
  • Çerçeve biçemleri metin dağılım türü, sınırlar, arkaplan ve sütunlar dahil metin çerçeveleri ve grafikleri biçimlendirmek için kullanılır.
  • Numaralama biçemleri benzer şekilde hizalama, numaralama veya madde imi karakterleri ve numaralı ve madde imli listeler için yazı tipleri uygular.
  • Hücre biçemleri yazı tiplerini, hizalamayı, sınırları, arkaplanı, sayı biçemlerini (örneğin, para birimi, tarih, sayı) ve hücre korumasını kapsar.
  • Grafik biçemleri çizimlerde ve sunumlarda satır, alan, gölgeleme, saydamlık, yazı tipi, bağlayıcılar, boyutlandırma ve diğer nitelikleridir.
  • Sunum biçemleri yazı tipi, girinti, boşluk, hizalama ve sekmeler için nitelikleri içerir.

Tablo 1'de listelendiği gibi LibreOffice'in çeşitli bileşenlerinde farklı biçemler kullanılabilir.

LibreOffice birçok öntanımlı bileşenlerle gelmektedir. Biçemleri bu bölümde anlatıldığı üzere olduğu gibi kullanabilirsiniz, değiştirebilirsiniz veya yeni biçemler oluşturabilirsiniz.

Tablo 1. LibreOffice bileşenlerinde kullanılabilen biçemler


Biçem Türü Writer Calc Draw Impress
Sayfa X X
Paragraf X
Karakter X
Çerçeve X
Numaralama X
Hücre X
Sunum X X
Grafikler (Çerçeve biçemlerinde dahil) X X

Biçemleri uygulamak

LibreOffice seçilen biçemi uygulamak için bir kaç yol sunmaktadır.

Biçemler ve Biçimlendirme penceresini kullanmak

  1. Nesne çubuğunun sol ucunda bulunan Biçimler ve Biçimlendirme simgesini tıklayın veya Biçimlendir → Biçemler ve Biçimlendirme yolunu seçin veya F11'e basın. Biçemler ve Biçimlendirme penceresi kullandığınız LibreOffice bileşeni için kullanılabilir biçem türlerini gösterir. Şekil 1 Writer için Biçemler ve Biçimlendirme penceresini gösteriyor.

Bu pencereyi ekranda uygun bir konuma taşıyabilirsiniz veya bir köşeye kitleyebilirsiniz (Ctrl tuşuna basılı tutun ve kitlemek istediğiniz yere başlığından tutarak sürükleyin).

  1. Belirli bir gruptaki biçemlerin listesini görüntülemek için Biçemler ve Biçimlendirme penceresinin sol üstündeki simgelerden birini tıklayın.
  2. Var olan bir biçemi uygulamak için (karakter biçemlerinin dışınsa), paragraf, çerçeve veya sayfadaki ekleme noktasını konumlandırın ve bu listelerdeki bir biçemin ismini çift tıklayın. Karakter biçemini uygulamak için önce karakteri seçin.


İpucu Biçemler ve Biçimlendirme penceresinin altında açılır bir liste vardır. Şekil 1'de pencere, sadece LibreOffice tarafından otomatik olarak uygulanan biçemleri içerdiği anlamında Otomatik'i gösteriyor. Tüm biçemleri veya diğer grupları göstermeyi seçebilirsiniz. Örnek, sadece özel biçemler.
[[Image:|thumb|Şekil 1: Writer için Biçemler ve Biçimlendirme penceresi, sayfa biçemlerini gösteriyor]]

Doldurma Biçim Kipini kullanmak

Bir biçemi Biçemler ve Biçimlendirme penceresine gitmeden ve her seferinde çift tıklamadan birçok farklı alanda hızlı bir şekilde uygulamak için Doldurma Biçimini kullanın. Bu yöntem dağınık paragrafları, hücreleri veya diğer ögeleri aynı biçemle biçimledirmeye ihtiyacınız olduğunda çok faydalıdır.

  1. Biçemler ve Biçimlendirme penceresini açın ve uygulamak istediğiniz biçemi seçin.
  2. Doldurma Biçim Kipi simgesini tıklayın.
  3. Bir paragraf, sayfa veya çerçeve biçemini uygulamak için fareyi paragraf, sayfa veya çerçeve üzerinde tutun ve tıklayın. Bir karakter biçemi uygulamak için karakterleri seçerken fare düğmesin basılı tutun, bir kelime üzerinde tıklama karakter biçemini o kelimeye uygular. Bu biçem için tüm değişiklikleri yapana kadar 3ncü maddeyi tekrarlayın.
  4. Doldurma Biçim kipinden çıkmak için Doldurma Biçim Kipi simgesini tekrar tıklayın veya Esc tuşuna basın.


Dikkat


Bu kip açıkken belgedeki bir yere sağ tıklamak Doldurma Biçim eyleminde son yapılan değişikliği geri alır. Kazara sağ tıklamamak için dikkatli olun ve böylece muhafaza etmek istediğiniz eylemleri geri almayın.

Biçemi Uygula listesini kullanmak

Bir biçemi bir belgede en az bir defa kullandıktan sonra o biçemin adı Biçimlendirme araç çubuğunun sol ucundaki Biçemler ve Biçimlendirme simgesinin yanında bulunan Biçemi Uygula listesinde görünür.

Bu listeyi açabilir ve istediğiniz biçemi hemen tıklayabilirsiniz veya listede gezinmek için aşağı ve yukarı ok tuşlarını kullanabilirsiniz ve vurgulanan biçemi uygulamak için Enter'a basın.


İpucu Biçemler ve Biçimlendirme penceresini açmak için Biçemi Uygula listesinin altındaki Daha Fazla...'yı seçin.
[[Image:|thumb|Şekil 2: Biçimlendirme araç çubuğundaki Biçemi Uygula listesi]]

Klavye kısayollarını kullanmak

Biçemleri uygulama için bazı klavye kısayolları öntanımlıdır. Örneğin, Writer'da Ctrl+0 metin gövde biçemini, Ctrl+1 Başlık 1 biçemini ve Ctrl+2 Başlık 2 biçemini uygular. Bu kısayolları değiştirebilirsiniz ve kendiniz için kısayollar oluşturabilirsiniz; bilgi için Bölüm 14 LibreOffice'i Özelleştirmek konusuna bakın.

Biçemleri değiştirmek

LibreOffice biçemleri (hem öntanımlı hem de kendi oluşturduğunuz özel biçemler) değiştirmek için birkaç yol sunar :

  • Biçem penceresini kullanarak bir biçemi değiştirmek
  • Seçimden bir biçemi güncellemek
  • Otomatik Güncelle'yi kullanmak (sadece paragraf ve çerçeve biçemleri)
  • Başka bir belge veya şablondan biçemleri yüklemek veya kopyalamak


İpucu Bir biçemde yaptığınız değişiklik sadece geçerli belgeyi etkiler. Biçemleri birden fazla belgede değiştirmek için şablonu değiştirmeniz gerekir veya sayfa 11'de anlatıldı gibi biçemleri diğer belgelere kopyalamalısınız.

Biçem penceresini kullanarak bir biçemi değiştirmek

Biçem penceresini kullanarak var olan bir biçemi değiştirmek için Biçemler ve Biçimlendirme penceresinde gerekli biçem üzerinde sağ tıklayın ve açılan menüden Değiştir'i seçin.

Biçem penceresi seçilen biçem türüne bağlı olarak görüntülenir. Her biçem penceresi birkaç sekmeye sahiptir. Ayrıntılar için kullanıcı kılavuzundaki biçemler bölümüne bakın.

Bir seçimden bir biçemi güncellemek

Bir seçimden bir biçemi güncellemek için:

  1. Biçemler ve Biçimlendirme penceresini açın
  2. Belgede, bir biçem olarak edinmek istediğiniz biçimlendirilmiş bir ögeyi seçin.


Dikkat


Bu paragrafta benzersiz özellikler olduğundan emin olun. Örneğin, eğer iki farklı yazı tipi boyutu veya yazı tipi biçemi varsa bu belirli nitelik önceden olduğu gibi kalacaktır.
  1. Biçemler ve Biçimlendirme penceresinde güncellemek istediğini biçemi seçin (iki değil, tek tıklayın) sonra Seçimden Yeni Biçem simgesinin yanındaki oku tıklayın ve Biçemi Güncelle'yi tıklayın.
[[Image:|thumb|Şekil 3: Seçimden bir biçemi güncellemek]]

Otomatik Güncelle'yi kullanmak

Otomatik Güncelle sadece paragraf ve çerçeve biçemlerini uygular. Eğer Paragraf Biçemi veya Çerçeve biçemi penceresinin Yönetici sayfasında Otomatik Güncelleme seçilmişse belgenizdeki bu biçemi kullanarak bir paragraf veya çerçeveye doğrudan biçimlendirme uygulaması otomatik olarak biçemin kendisini güncelleyecektir.


İpucu Belgenizdeki biçemlere elle müdahale ediyorsanız, Otomatik Güncelleme'nin etkin olmadığından emin olun.

Bir belge veya şablondan biçemleri güncellemek

Bir şablondan veya başka bir belgeden biçemleri kopyalayarak veya yükleyerek güncelleyebilirsiniz. Sayfa 11'deki “Biçemleri kopyalamak ve taşımak” konusuna bakınız.

Yeni (özel) biçemler oluşturmak

Yeni biçemler eklemek isterseniz bunu iki şekilde yapabilirsiniz:

  • Biçem iletişim penceresini kullanarak yeni bir biçem oluşturmak
  • Bir seçimden yeni bir biçem oluşturmak

Biçem iletişim penceresini kullanarak yeni bir biçem oluşturmak

Biçem iletişim penceresini kullanarak yeni bir biçem oluşturmak için Biçemler ve Biçimlendirme penceresinde sağ tıklayın ve açılan menüden Yeni'yi seçin.

Yeni oluşturduğunuz bir biçemin var olan bir biçem ile bağlantılı olmasını istiyorsanız önce o biçemi seçin sonra sağ tıklayın ve Yeni'yi seçin.

Eğer biçemleri bağlantılarsanız daha sonra ana biçemi değiştirdiğinizde (örneğin, yazı tipini Times'tan Helvetica'ya değiştirerek) tüm bağlantılı biçemler de değişecektir. Bazen bu tam istediğiniz şeydir; başka bir zaman da bütün bağlantılı biçemlere uygulamak istemediğiniz şeydir.

İletişim pencereleri ve seçimler yeni bir biçem tanımlamak ve var olan bir biçemi değiştirmek için aynıdır. Ayrıntılar için kullanıcı kılavuzunun biçemler bölümlerine bakınız.

Bir seçimden yeni bir biçem oluşturmak

Var olan bir elle biçimlendirmeyi kopyalayarak yeni bir biçem oluşturabilirsiniz. Bu yeni biçem sadece bu beleye uygulanır; şablon olarak kaydedilmeyecektir.

  1. Biçemler ve Biçimlendirme penceresini açın ve oluşturmak istediğiniz biçem türünü seçin.
  2. Belgede biçem olarak kaydetmek istediğiniz ögeyi seçin.
  3. Biçemler ve Biçimlendirme penceresinde Seçimden Yeni Biçem simgesini tıklayın.
  4. Biçem Oluştur iletişim penceresinde yeni biçem için bir isim girin. Liste seçilen türün oluşturulmuş özel biçemlerinin isimlerini gösterir. Yeni biçemi kaydetmek için Tamam'ı tıklayın.
[[Image:|thumb|Şekil 4: Seçimden oluşturulmuş yeni biçemi isimlendirmek]]

Yeni bir biçem oluşturmak için Sürüklemek ve Bırakmak

Yeni bir biçem oluşturmak için bir metin seçimini Biçemler ve Biçimlendirme penceresine sürükleyin ve bırakın.

Writer (Kelime İşlemci)

Metni seçin ve Biçemler ve Biçimlendirme penceresine sürükleyin. Eğer Paragraf Biçemleri etkinse paragraf biçemi listeye eklenmiş olacaktır. Karakter Biçemi etkinse karakter biçemi listeye eklenmiş olacaktır.

Calc (Hesap Tablosu)

Hücre biçemleri oluşturmak için bir hücre seçimini Biçemler ve Biçimlendirme penceresine sürükleyin.

Draw/Impress (Çizim/Sunum)

Grafik biçemleri oluşturmak için çizim nesnelerini seçin ve Biçemler ve Biçimlendirme penceresine sürükleyin.

Biçemleri kopyalamak ve taşımak

Bir şablon veya belgeden biçemleri başka bir şablon veya beleye iki şekilde kopyalayabilir veya taşıyabilirsiniz:

  • Şablon Yönetimi penceresini kullanarak
  • Bir şablon veya belgeden biçemleri yükleyerek

Şablon Yönetimim penceresini kullanarak

Şablon Yönetimi penceresini kullanarak biçemleri kopyalamak veya taşımak için:

  1. Dosya → Şablonlar → Yönet... yolunu seçin.
  2. Şablon Yönetimi penceresinde (Şekil 5), listeleri ihtiyacınız gibi ya Şablonlar ya da Belgeler olarak alttan ayarlayın.


İpucu Açık olmayan bir dosyadan biçemleri kopyalamak için Dosya düğmesini tıklayın. Bu iletişim penceresine geri döndüğünüzde iki listede tüm geçerli açık belgelerin yanında seçilen dosyayı da gösterir.
  1. Dizinleri açın ve bir yerden başka bir yere kopyalamak istediğiniz şablonları bulun. Belgenin veya şablonun isminin üzerinde çift tıklayın ve özgün biçemlerin listesini görmek için Biçemler simgesini çift tıklayın (Şekil 6).
  2. Bir biçemi kopyalamak için Ctrl tuşuna basılı tutun ve biçemin adını bir listeden diğerine sürükleyin.


Dikkat


Eğer sürüklerken Ctrl tuşuna basılı tutmazsanız biçem bir listeden diğerine taşınmış olacaktır. Biçem tuttuğunuz listeden silinir.
  1. Kopyalamak istediğiniz her biçem için tekrar edin. Eğer aldığınız şablon veya belge çok fazla biçem içeriyorsa listeyi kaydırmadıkça değişiklikleri göremezsiniz. Bitirdiğinizde Kapat'ı tıklayın.
[[Image:|thumb|Şekil 5: Bir belgeden (şablon değil) biçemleri kopyalamak için seçmek ]]
[[Image:|thumb|Şekil 6: Bir belgeden diğerine bir biçemi kopyalamak]]

Bir şablon veya belgeden biçemleri yüklemek

Bir şablondan veya başka bir belgeden biçemleri yükleyerek kopyalayabilirsiniz:

  1. Biçemleri içine kopyalamak istediğiniz belgeyi açın.
  2. Biçemler ve Biçimlendirme penceresinde, Seçimden Yeni Biçem simgesinin yanındaki oku tıklayın ve sonra Biçemler Yükle'yi tıklayın. (Şekil 3'e bakın).
  3. Biçemleri Yükle penceresinde (Şekil 7), biçemlerini kopyalayacağınız şablonu bulun ve seçin.
[[Image:|thumb|Şekil 7. Bir şablondan açık belgeye biçemleri kopyalamak]]
  1. Kopyalanacak biçemlerin gruplarını seçin. Eğer kopyalanan biçemin içine kopyaladığınız belgedeki aynı isme sahip bir biçemle değiştirilmesini istiyorsanız Üzerine yaz'ı seçin.
  2. Biçemleri kopyalamak için Tamam'ı tıklayın. Ekranda bir değişiklik görmeyeceksiniz.


Not Başka bir belgeden biçemleri kopyalamak için Dosyadan düğmesini tıklayın ve açılan pencereden gerekli belgeyi seçin.
Dikkat


Belgenizde içindekiler tablosu varsa ve başlıklar için özel biçemler kullanmışsanız biçemleri bu şekilde yüklediğinizde başlık seviyeleri Başlık 1, Başlık 2 vb.'nin varsayılanına geri döndürecek anahat seviyeleri (Araçlar → Anahat Numaralama'da) ile birleştirilir. Özel başlık biçemlerinize geri değiştirmeniz gerekecek.

Biçemleri silmek

LibreOffice'in öntanımlı biçemlerini bir belgeden veya şablondan kullanımda olmasa bile (kaldıramazsınız) silemezsiniz.

Kullanıcı tanımlı (özel) biçemleri kaldırabilirsiniz (silebilirsiniz); ancak yapmadan önce artık kullanımdan olmadığından emin olmalısınız. İstenmeyen bir biçem kullanımda ise başka bir biçemle değiştirmek isteyebilirsiniz.

İstenmeyen biçemleri silmek için Biçemler ve Biçimlendirme penceresinde ilgili biçemi sağ tıklayın ve açılan menüden Sil'i tıklayın.

Eğer biçem kullanımda ise bir uyarı iletisi alırsınız.


Dikkat


Silmeden önce biçemin kullanımda olmadığından emin olun. Aksi halde o biçemle biçimlendirilmiş tüm nesneler varsayılan biçeme döndürülür ve biçimleri elle biçimlendirildiği gibi muhafaza edilir.

Biçem kullanımda değilse bir onaylama iletisi alırsınız; biçemi silmek için Evet'i tıklayın.

Bir belge oluşturmak için şablon kullanmak

Belge oluşturmak için şablon kullanmak:

  1. Ana menüden Dosya → Yeni → Şablonlar ve Belgeler'i seçin. Şablonlar ve Belgeler penceresi açılır.
  2. Soldaki kutuda halihazırda seçilmemişse Şablonlar simgesini tıklayın. Şablon dizinlerinin bir listesi orta kutuda görünür.
  3. Kullanmak istediğiniz şablonları içeren dizini çift tıklayın. Dizindeki şablonların bir listesi orta kutuda görünür.
  4. Kullanmak istediğiniz şablonu seçin. Seçilen şablonu önizleme yapabilirsiniz veya şablonun özelliklerini görebilirsiniz:
    • Şablonu önizleme yapmak için Önizleme simgesini tıklayın. Sağdaki kutuda şablonun bir önizlemesi görünür.
    • Şablonun özelliklerini görüntülemek için Belge Özellikleri simgesini tıklayın. Sağdaki kutuda şablonun özellikleri görünür.
  1. Aç'ı tıklayın. Şablonlar ve Belgeler penceresi kapanır ve LibreOffice'de seçilen şablon temelli yeni bir belge açılır. Diğer belgelerde olduğu gibi yeni belgeyi de düzenleyebilir ve kaydedebilirsiniz.
[[Image:|thumb|Şekil 8: Şablonlar ve Belgeler penceresi]]

Şablon oluşturmak

İki şekilde kendi şablonlarınızı oluşturabilirsiniz: bir belgeden ve sihirbaz kullanarak.

Bir belgeden şablon oluşturmak

Bir belgeden şablon oluşturmak için:

  1. Bir şablon yapma istediğiniz türde yeni veya var olan bir belgeyi açın (metin belgesi, hesap tablosu, çizim, sunum).
  2. İstediğiniz içerik ve biçemleri ekleyin.
  3. Ana menüden Dosya → Şablonlar → Kaydet yolunu seçin. Şablonlar penceresi açılır ( Şekil 9'a bakın).
  4. Yeni Şablon alanında yeni şablon için bir isim girin.
  5. Kategoriler listesinde, şablonu atamak istediğiniz kategoriyi tıklayın. Seçtiğiniz kategorinin şablon üzerinde kendi kendisine bir etkisi yoktur; sadece şablonu kaydettiğiniz bir dizindir. Uygun bir kategoriyi seçmek kullanmak istediğinizde şablonu bulmanızı kolaylaştırır. Örneğin, Impress (sunum) şablonlarını Sunular altında kaydetmek isteyebilirsiniz.

Şablon dizinleri hakkında daha fazlasını öğrenmek için sayfa 20'deki “Şablonları yönetmek” konusuna bakın.

  1. Yeni şablonu kaydetmek için Tamam'ı tıklayın.
[[Image:|thumb|Şekil 9: Yeni bir şablonu kaydetmek]]

Bir belgedeki eklenebilen veya değiştirilebilen bir ayar bir şablona kaydedilebilir. Örneğin, aşağıda bir Writer (kelime işlemci) belgesinde bulunan ve sonraki kullanım için bir şablon olarak kaydedilen ayarların bazıları (tam bir liste olmamasına rağmen) bulunmaktadır:

  • Yazıcı ayarları: hangi yazıcı, tek yön/çift yön, kağıt boyutu vb..
  • Kullanılacak biçemler, karakter, sayfa, çerçeve, numaralama ve paragraf biçemleri dahil
  • Dizinler, tablolar, bibliyografiler, içindekiler tabloları ile ilgili biçim ve ayarlar.

Şablonlar her yeni belge oluşturduğunuzda yazmanız için öntanımlı metinler sunarlar. Örneğin, bir mektup şablonu isim, adres ve selamlama içerir.

Şablonlarda menü ve araç çubuğu özelleştirmelerini de kaydedebilirsiniz; daha fazla bilgi için Bölüm 14, LibreOffice'i Özelleştirmek konusuna bakın.

Sihirbaz kullanarak bir şablon oluşturmak

Mektuplar, fakslar, ajandalar, sunumlar ve Web sayfaları için şablon oluşturmak maksadıyla sihirbazları kullanabilirsiniz.

Örneğin, Faks sihirbazı aşağıdaki seçimlerde rehberlik eder:

  • Faksın türü (iş veya kişisel)
  • Tarih, konu satırı (iş faksı), selamlama, ve bitirme kapanışı gibi belge ögeleri
  • Gönderen ve alıcı bilgileri için seçenekler (iş faksı)
  • Alt bilgideki metin (iş faksı)

Sihirbaz kullanarak bir şablon oluşturmak:

  1. Ana menüden Dosya → Sihirbazlar → [gerekli şablonun türü].
[[Image:|thumb|Şekil 10. Sihirbaz kullanarak bir şablon oluşturmak]]
  1. Sihirbaz sayfasındaki talimatları takip edin. Bu süreç her şablon türü için biraz farklıdır fakat biçimi çok yakındır.
  2. Sihirbazın son bölümünde şablonu kaydetmek için isim ve yer belirleyebilirsiniz. Varsayılan konum kullanıcı şablon dizinidir ancak isterseniz farklı bir yer seçebilirsiniz.
  3. Son olarak şablonlarınızdan hızlı bir şekilde yeni bir belge oluşturma veya şablonu elle değiştirme şansına sahip olursunuz. Sonraki belgeler için diğer şablonları kullanabileceğiniz gibi sihirbazla oluşturulan şablonları yeniden kullanabilirsiniz.

Bir şablonu düzenlemek

Bir şablonun biçemlerini ve içeriğini düzenleyebilirsiniz ve sonra isterseniz o şablondan oluşturulan belgelere şablonun biçemlerini yeniden uygulayabilirsiniz. (Sadece biçemleri yeniden uygulayabileceğinize dikkat edin. İçeriği yeniden uygulayamazsınız.)

Bir şablonu düzenlemek için:

  1. Ana menüden Dosya → Şablonlar → Düzenle yolunu seçin. Standart bir dosya tarayıcı penceresi açılır.
  2. Düzenlemek istediğini şablonu seçin.
  3. Diğer belgelerde yaptığınız gibi şablonu düzenleyin. Değişiklikleri kaydetmek için ana menüden Dosya → Kaydet'i seçin.

Değiştirilen bir şablondan bir belgeyi güncellemek

Değiştirilmiş bir şablondan oluşturulmuş bir belgeyi daha sonra açtığınızda aşağıdaki ileti görünür.

[[Image:|thumb|Şekil 11. Biçemleri güncelle iletisi]]

Şablonun değişen biçemlerini belgeye uygulamak için Biçemleri Güncelle'yi tıklayın. Eğer değişen biçemleri belgeye uygulamak istemiyorsanız Eski Biçemleri Koru'yu tıklayın (ancak aşağıdaki uyarıya dikkat edin).


Dikkat


Eğer Şekil 11'de gösterilen ileti kutusundaki Eski Biçemleri Koru'yu seçerseniz bu ileti belgenin temellendirildiği şablondaki değişiklikten sonra belgeyi açtığınızda görünmeyecektir. Bu özelliği yeniden etkinleştirmek için aşağıdaki notta aşağıda verilen makroyu kullanabilmenize rağmen şablondan biçemlerin güncellenmesi için başka bir şansınız olmayacak.

Eğer Writer kullanıyorsanız şablonu yeniden atamak için Şablon Değiştirici eklentisini de kullanabilirsiniz (sayfa 19'e bakın).

Not Bir şablondan etkinleştirmeyi yeniden etkinleştirmek:
  1. Araçlar → Makrolar → Makroları Yönet → LibreOffice Basic... yolunu seçin. Listeden belgeyi seçin, genişletme simgesini tıklayın (+ veya üçgen) ve Standart'ı seçin. Eğer Standart'ın yanında bir genişletme simgesi varsa onu tıklayın ve bir modül seçin.
  2. Eğer Düzenle düğmesi etkinse tıklayın. Etkin değilse Yeni'yi tıklayın.
  3. Basic penceresinde, aşağıdaki kodu girin:

Sub FixDocV3 ' set UpdateFromTemplate oDocSettings = ThisComponent.createInstance( _ "com.sun.star.document.Settings" ) oDocSettings.UpdateFromTemplate = True End Sub 'FixDocV3

  1. BASIC çalıştır simgesini tıklayın, sonra Basic penceresini kapatın.
  2. Belgeyi kaydedin.

Daha sonra bu belgeyi açtığınızda değiştirilen şablondan biçemleri güncellemek için yönlendirilmiş olacaksınız.

Eklenti yöneticisini kullanarak şablonlar eklemek

Eklenti Yöneticisi .OXT uzantılı bir dosya içerisinde "paketlenmiş" şablonların, grafiklerin, makroların ve diğer eklentilerin derlemelerini kurmak için kolay bir yol sunar. Eklenti Yöneticisi hakkında daha fazla bilgi için Bölüm 14, LibreOffice'i Özelleştirmek konusuna bakın.

Aşağıdaki adreste kullanılabilir eklenti listeleri bulunmaktadır:

http://extensions.libreoffice.org/.

Bir eklentiyi kurmak içi aşağıdaki adımları takip edin:

  1. Eklentiyi indirin ve bilgisayarınızda bir yere kaydedin.
  2. LibreOffice'de, menü çubuğundan Araçlar → Eklenti Yöneticisi'ni seçin. Eklenti Yöneticisi penceresinde Ekle'yi tıklayın.
  3. Bir dosya tarayıcısı açılır. Yüklemek istediğiniz şablonların paketini bulun ve seçerek Aç'ı tıklayın. Paket yüklenmeye başlar. Bir lisans anlaşmasını kabul etmeniz istenebilir.
  4. Paket yüklenmesi tamamlandığında şablonlar Dosya → Yeni → Şablonlar ve Belgeler yolunda kullanım için hazırdır ve eklenti Eklenti Yöneticisinde listelenir.
[[Image:|thumb|Şekil 12: Yeni eklenmiş şablonların paketleri]]

Varsayılan şablonu ayarlamak

Dosya → Yeni → Metin Belgesi (veya Hesap Tablosu, Sunum veya Çizim) yolunu seçerek bir belge oluşturursanız LibreOffice belgeyi o belgenin varsayılan şablonundan oluşturur. Ancak özel bir şablonu varsayılan olarak ayarlayabilirsiniz. İsterseniz daha sonra varsayılana sıfırlayabilirsiniz.

Özel bir şablonu varsayılan olarak ayarlamak

Herhangi bir şablonu varsayılan olarak ayarlayabilirsiniz yeter ki Şablon Yönetici penceresindeki dizinlerden birinde olsun.

Özel bir şablonu varsayılan olarak ayarlamak:

  1. Ana menüden Dosya → Şablonlar → Yönet'i seçin. Şablon Yönetimi penceresi açılır.
  2. Soldaki kutuda varsayılan olarak ayarlamak istediğiniz şablonu içeren dizini seçin ve sonra şablonu seçin.
  3. Komutlar düğmesini tıklayın ve açılan menüden Varsayılan Şablon Olarak Tanımla'yı seçin.

Daha sonra Dosya → Yeni yolunu kullanarak bir belge oluşturduğunuzda belge bu şablondan oluşturulur.

Seçenekler penceresinde (Bölüm 2'ye bakın) varsayılan yazı tipi ve boyutu gibi birçok önemli ayarlar değiştirilebilmesine rağmen daha gelişmiş ayarlar (sayfa yazdırma alanı gibi) sadece varsayılan şablonu yeni biriyle değiştirerek değiştirilebilir.

Varsayılan şablona sıfırlamak

Varsayılan olan bir belge türünü yeniden LibreOffice'in Varsayılan şablonuna sıfırlamak:

  1. Şablon Yönetimi penceresinde sol kutudaki bir dizini tıklayın.
  2. Komutlar düğmesini tıklayın ve açılan menüden Varsayılan Şablona Sıfırla'yı seçin.

Daha sonra Dosya → Yeni yolunu kullanarak bir belge oluşturduğunuzda belge LibreOffice'in Varsayılan şablonundan oluşturulur.

Farklı bir şablonla bir belgeyi birleştirmek

Bir belgeyi farklı bir şablonla birleştirmek isteyebilirsiniz veya bir şablondan başlatılmamış bir belge ile çalışıyor olabilirsiniz.

Sayfa 16'de anlatıldığı gibi şablonları kullanmanın genel avantajlarından biri bir belgeden daha çok biçemleri güncelleme kolaylığıdır. Farklı bir şablondan yeni bir biçem kümesi yükleyerek biçemleri güncellerseniz (sayfa 12'de anlatıldığı gibi) belge biçemlerin yüklendiği şablonla birleştirilmez – böylece bu yöntemi kullanamazsınız. Farklı şablonla belgeyi birleştirmek için neye ihtiyacınız var?

Bunu iki şekilde yapabilirsiniz. İki durumda da en iyi sonuç için yeni şablonla var olan belgedeki biçemlerin isimleri aynı olmalıdır. Değilse eski biçemleri yenisiyle değiştirmek için Bul ve Değiştir'i kullanmanız gerekecek. Bul ve Değiştir'i kullanarak biçemleri değiştirme hakkında daha fazla bilgi için Bölüm 4 "Writer ile başlamak konusuna" bakın.

Yöntem 1

Bu yöntem biçemlerin yanında grafik ve üslupları (resmi ilan gibi) kapsar. Bu materyali istemiyorsanız silmelisiniz.

  1. Dosya → Yeni → Şablonlar ve Belgeler'i seçin. İstediğiniz şablonu seçin. Eğer şablon istenmeyen metin veya grafikler içeriyorsa onları silin.
  2. Değiştirmek istediğiniz belgeyi açın. (Yeni bir pencere açar.) Belgedeki her şeyi seçmek için Ctrl+A'ya basın. 1'nci adımda oluşturduğunuz boş belgeye yapıştırın.
  3. Varsa İçindekiler tablosunu güncelleyin. Dosyayı kaydedin.

Yöntem 2 (sadece Writer)

Bu yöntem yeni bir şablondan grafik ve metin içermez; basitçe yeni şablondan biçemleri alır ve şablon ve belge arasında bir birleşme tesis eder.

  1. http://extensions.libreoffice.org/ adresinden Şablon Değiştirici (Template Changer) eklentisini indirin ve sayfa 17'da anlatıldığı gibi yükleyin.
  2. LibreOffice'i kapatın ve yeniden açın. Writer'da artık Doya → Şablonlar menüsünün iki yeni seçeneği vardır: Şablonu Ata (geçerli belge) ve Şablonu Ata (dizin). Calc, Impress ve Draw'da Şablonu Ata (dizin) seçeneği kullanılabilir.
  3. Şablonunu değiştirmek istediğiniz belgeyi açın. Dosya → Şablonlar → Şablonu Ata (geçerli belge) yolunu seçin.
  4. Şablon Seç penceresinde gerekli şablonu bulup seçin ve Aç'ı tıklayın.
  5. Belgeyi kaydedin. Şimdi Dosya →Özellikler'e bakarsanız Genel sayfasının altında yeni şablonun listelendiğini göreceksiniz.

Şablonları yönetmek

LibreOffice sadece LibreOffice şablonlar dizininde bulunan şablonları kullanır. Yeni LibreOffice şablon dizinleri oluşturabilirsiniz ve şablonlarınızı yönetmek için kullanabilirsiniz. Örneğin, bir şablon dizinini rapor şablonları ve başka birini mektup şablonları için kullanırsınız. Ayrıca şablonları içe ve dışa aktarabilirsiniz.

Başlamak için ana menüden Dosya → Şablonlar → Yönet'i seçin. Şablon Yönetimi penceresi açılır.


Not Şablon Yönetimi penceresinde Komutlar düğmesiyle yapılan tüm eylemler şablonlar ve dizinleri sağ tıklayarak da yapılabilir.

Bir şablon dizini oluşturmak

Bir şablon dizini oluşturmak:

  1. Şablon Yönetimi penceresinde bir dizini tıklayın.
  2. Komutlar düğmesini tıklayın ve açılan menüden Yeni'yi tıklayın. İsimsiz olarak adladırılan yeni bir dizin görünür.
  3. Yeni dizin için bir isim yazın ve Enter'a basın. LibreOffice girdiğiniz isimle dizini kaydeder.

Bir şablon dizinini silmek

LibreOffice ile desteklenen veya Eklenti Yöneticisi kullanılarak yüklenmiş şablon dizinlerini silemezsiniz; sadece kendi oluşturduğunuz şablon dizinlerini silebilirsiniz.

Kendi oluşturduğunuz bir şablon dizinini silmek:

  1. Şablon Yönetimi penceresinde silmek istediğiniz dizini seçin.
  2. Komutlar düğmesini tıklayın ve açılan menüden Sil'i tıklayın. Silmeyi onaylamanızı isteyen bir ileti kutusu açılır. Evet'i tıklayın.

Bir şablonu taşımak

Bir şablonu bir dizinden başka bir dizine taşımak:

  1. Şablon Yönetimi penceresinde taşımak istediğiniz şablonu içeren dizini çift tıklayın. Dizindeki şablonların bir listesi dizin adının altında görünür.
  2. Taşımak istediğiniz şablonu tıklayın ve istediğiniz dizine sürükleyin. Kaynak dizinden şablonları silmek için yetkiniz yoksa şablonu taşımak yerine kopyalar.

Bir şablonu silmek

LibreOffice ile desteklenen veya Eklenti Yöneticisi kullanılarak yüklenmiş şablonları silemezsiniz; sadece kendi oluşturduğunuz veya içe aktardığınız şablonları silebilirsiniz.

Bir şablonu silmek:

  1. Şablon Yönetimi penceresinde silmek istediğiniz şablonu içeren dizini çift tıklayın. Dizindeki şablonların bir listesi dizin adının altında görünür.
  2. Silmek istediğiniz şablonu tıklayın.
  3. Komutlar düğmesini tıklayın ve açılan menüden Sil'i seçin. Silmeyi onaylamanızı soran bir ileti kutusu görünür. Evet'i tıklayın.

Bir şablonu içe aktarmak

Bir şablonu farklı bir yerde kullanmak istiyorsanız LibreOffice şablon dizinine aktarmalısınız.

Bir şablonu bir şablon dizinine aktarmak:

  1. Şablon Yönetimi penceresinde şablonu içe aktarmak istediğiniz dizini seçin.
  2. Komutlar düğmesini tıklayın ve açılan pencereden Şablonu İçe Aktar'ı seçin. Standart dosya tarayıcı penceresi açılır.
  3. İçe aktarmak istediğiniz şablonu bulup seçin ve Aç'ı tıklayın. Dosya tarayıcı penceresi kapanır ve şablon seçilen dizinde görünür.
  4. İsterseniz şablon için yeni bir isim yazın ve Enter'a basın.

Bir şablonu dışa aktarmak

Bir şablonu bir dizinden başka bir yere aktarmak:

  1. Şablon Yönetimi penceresinde dışa aktarmak istediğiniz şablonu içeren dizini çift tıklayın. Dizindeki şablonların bir listesi dizin adının altında görünür.
  2. Dışa aktarmak istediğiniz şablonu seçin.
  3. Komutlar düğmesini tıklayın ve açılan menüden Şablonu Dışa Aktar'ı seçin. Farklı Kaydet penceresi açılır.
  4. Şablonu aktarmak istediğiniz dizini bulun ve Kaydet'i tıklayın.

Biçem kullanma örnekleri

Sayfa ve paragraf biçemlerinin genel kullanımının aşağıdaki örnekleri Writer'dan alınmıştır. Biçemlerin kullanımı için birkaç yol daha vardır; ayrıntılar için çeşitli bileşenlerin kılavuzlarına bakın.

Bir belge için farklı bir ilk sayfa belirlemek

Mektuplar ve raporlar gibi birçok belgenin ilk sayfası diğer sayfalardan farklıdır. Örneğin, bir mektubun ilk sayfasının standart olarak farklı bir üst bilgisi vardır veya bir raporun ilk sayfasında üst bilgi ve alt bilgi yokken diğer sayfalarda vardır. LibreOffice ile ilk sayfa için bir sayfa biçemi tanımlayabilirsiniz ve sonraki sayfalara otomatik olarak uygulanacak biçemi belirleyebilirsiniz.

Örnek olarak, LibreOffice ile gelen İlk Sayfa ve Varsayılan biçemlerini kullanabiliriz. Şekil 13 Olmasını istediğimiz şeyi gösteriyor: ilk sayfa varsayılan sayfa ile takip ediliyor ve bütün takip eden sayfalar Varsayılan sayfa biçeminde olacaktır. Ayrıntılar için Writer kılavuzundaki Bölüm 4 Sayfa Biçimlendirme konusuna bakınız.

[[Image:|thumb|Şekil 13: Sayfa biçemlerinin akışı]]

Bir belgeyi bölümlere ayırmak

Benzer şekilde bir belgeyi bölümlere ayırabilirsiniz. Yukarıdaki gibi her bölüm İlk Sayfa biçemi ile başlayacak ve takip eden sayfalar Varsayılan sayfa biçeminde olacaktır. Şekil 14'de gösterildiği gibi bölümün sonunda bir elle sonlandırma ekleyin ve sonraki bölümü başlatmak amacıyla sonraki sayfayı İlk Sayfa biçemini alması için belirleyin.

[[Image:|thumb|Şekil 14: Sayfa biçemleri kullanarak bir belgeyi bölümlere ayırmak]]

Bir belgedeki sayfa yönlendirmesini değiştirmek

Bir Writer belgesi farklı yönlerde sayfalar içerebilir. Genel bir durum diğer sayfalar dikeyken belgenin ortasında yatay bir sayfanın olmasıdır. Bu sayfa sonlandırma ve sayfa biçemleri ile de yapılabilir.

Sağ ve sol sayfalarda farklı üst bilgiler

Sayfa biçemleri karşılıklı yansıtılmış sağ ve sol sayfalar veya sadece sağ (bölümlerin ilk sayfaları genellikle sağ sayfa olarak tanımlanır) veya sadece sol olarak ayarlanabilir. Yansıtılmış sayfalar veya sağ ve sol sayfalar için sayfa biçem ayarlarında bir üst bilgi eklediğinizde tüm sayfaların üst bilgi içeriklerini aynı veya sağ ve solda farklı olur. Örneğin, sayfa numarasını sol sayfanın sol kenarına ve sağ sayfanın sağ kenarına, belge başlığını sadece sağ sayfaya koyabilirsiniz veya diğer değişiklikleri yapabilirsiniz.

Sayfa sonlandırmasını otomatik olarak denetlemek

Writer metni bir sayfada diğerine otomatik olarak kaydırır. Varsayılan ayarlardan hoşlanmıyorsanız değiştirebilirsiniz. Örneğin, yeni sayfada veya sütunda başlayacak bir paragrafa ve yeni sayfanın biçemini belirlemek isteyebilirsiniz. Özgün bir kullanımı bölüm başlıklarını daima yeni sağ sayfada (tek numaralı) başlatmaktır.

Bir otomatik içindekiler tablosu derlemek

Bir otomatik içindekiler tablosu derlemek için içindekiler listesinde görünmesini istediğiniz başlıklara biçemleri uyguladıktan sonra Writer'a içindekiler tablosunda hangi biçemin hangi seviye ile gideceğini belirtmek için Araçlar → Anahat Numaralama'yı kullanın. Daha fazla bilgi için Bölüm 4'e bakın.

Biçemlerin sırasını tanımlamak

Bir paragraf biçemini ayarlarsınız ki paragrafın sonunda Enter'a bastığınızda takip eden paragraf otomatik olarak uygulanmasını istediğiniz biçemi alır. Örneğin, Metin Gövdesi paragrafı ile takip edilecek bir Başlık 1 paragrafı tanımlarsınız. Daha karmaşık bir örnek: Başlık, Yazar, Özet, Başlık 1 Metin Gövdesi. Bu sırayı ayarlayarak biçemleri elle uygulamaktan kaçınabilirsiniz.