EĞERSAY

Libreoffice Türkiye Vikisi sitesinden
Atla: kullan, ara



Verilen şartı sağlayan hücrelerin sayısını bulur.


Yazım şekli

 =EĞERSAY(TestEdilecekAlan; Şart)

TestEdilecekAlan içerisindeki Şart'ı sağlayan hücrelerin sayısını verir.


Şart'ın özellikleri

Şart olarak sayısal veya metin ifadeleri girilebilir. Karşılaştırma operatörleri olarak <, >, <=, >=, = veya <> kullanılabilir. Şart çift tırnak ("...") içerisinde olmalıdır.


Örnek-1 : Sayısal karşılaştırma

 =EĞERSAY(A1:A3;">3")

Eğer A1:A3 hücreleri sırasıyla 2,9,4 sayılarını içeriyorsa sonuç 2 olacaktır. Çünkü şartımızda belirttiğimiz ">3" hücre içeriğinin 3'ten büyük olanların sayısını istediğimizi belirtmektedir.


Örnek-2 : Metin ifadelerini karşılaştırma

 =EĞERSAY(B2:B5;"Elma")

Eğer B2:B5 hücreleri sırasıyla Elma, Armut, Elma değerlerini içeriyorsa sonuç 2 olacaktır. Çünkü şartımızda belirttiğimiz "Elma" TestEdilecekAlan içerisindeki değeri Elma olanların sayısını verecektir.


Örnek-3 : Mantıksal ifadeleri karşılaştırma

 =EĞERSAY(B2:B5;"Doğru")

Eğer B2:B5 hücreleri sırasıyla Doğru, Yanlış, Yanlış değerlerini içeriyorsa sonuç 1 olacaktır. Çünkü şartımızda belirttiğimiz "Doğru" TestEdilecekAlan içerisindeki değeri Doğru olanların sayısını verecektir.


Eskiwiki.png This page is imported from Eskiwiki (previously Wiki.OpenOffice.org.tr) The whole page content and all revisions are licensed under:
24px24px This work is licensed under the Attribution NonCommercial 3.0 Unported License