Temel Draw özellikleri

Libreoffice Türkiye Vikisi sitesinden
Atla: kullan, ara



OpenOffice.org Draw(Çizim), ölçeklenebilir vektörel çizim aracıdır. Hızlı ve etkili bir şekilde çizim oluşturabilmeniz için gereken tüm güçlü araçları sağlar. Draw, OpenOffice.org uygulaması ile birlikte gelir.

Draw, temel çizim ihtiyaçlarınızı karşılamakla birlikte sizlere güçlü 2D ve temel düzeyde 3D boyutlandırmalı nesneler oluşturma imkanı verir.

Draw bilinen çizim uygulamalarından çok daha ileri düzeyde güçlü katman desteği sunar. Sayfa bazlı çalışma, gerçek zamanlı ölçek tanımlayabilme, yazım denetimi gibi sıradışı özelliklere sahiptir.

Oluşturduğunuz bu nesnelere ışık, perspektif, doku vb. gibi materyaller kullanarak yeni özellikler kazandırıp gerçek resim kalitesinde çizim yapabilirsiniz. Çizim dosyalarınızı, yaygın olarak kullanılan (BMP, JPEG, GIF, PNG, TIFF vb.) biçimlerde dışarı resim olarak aktarabilirsiniz. Resim olarak dışarı aktarmada resim kalitesinide belirlemek mümkündür. Oluşturulan her türlü belgeyi dağıtmak için PDF olarak dışarı aktarma özelliği mevcuttur.

Bunun dışında diğer tüm OpenOffice.org bileşenleriyle %100 uyumlu olarak çalışır. Bu sayede çalışmalarınızı diğer OpenOffice.org bileşenlerine aktarabilirsiniz.

OpenOffice.org Draw (Çizim) Arayüzü

Draw programını başlattığımızda karşımıza aşağıdaki ara birim gelecektir.


Draw1.png


Bu ara birimde yer alan sayfamıza bir göz atalım. Varsayılan olarak karşımıza A4 kağıt ölçülerinde yani 21x29,70 cm'lik bir çalışma sayfası gelecektir. Draw'ın ana ekranında yer alan menüler, düğmeler ve araç çubukları diğer OpenOffice.org bileşenleri ile benzerlikler gösterir. Bu sebeple tek tek düğmelerin görevlerini bu yazımızda anlatmayacağız. Ancak temel olarak çizimin bir sayfaya yapılması gerektiğinden sayfa ayarlarını nasıl yapacağımıza değineceğiz. Bu ayarı, Biçim-->Sayfa yolunu takip ederek veya çalışma sayfasında farenin sağ tuşuna tıklayarak açılan menüden Sayfa-->Sayfa Yapısı bölümünden yapabilirsiniz. Bu pencerenin görünümü aşağıdaki gibidir.


Draw2.png



Draw3.png Çalışma sayfamızın üst ve sol tarafında yer alan cetveller yardımıyla yaptığımız çizimin boyutlarını takip etmek mümkündür.

Bu cetvel, varsayılan ölçü birimi olarak santimetreyi(cm) kullanmaktadır. Eğer başka bir ölçü birimini kullanmak isterseniz cetvel üzerinde farenin sağ tuşuna basarak gerekli ölçü birimine tıklamanız yeterli olacaktır.


Draw4.png Ana sayfanın sol tarafında bulunan sayfa penceresi sayesinde kaç adet sayfa üzerinde çalıştığınızı ve küçük bir ön izlemesini görebilirsiniz.

Bu özellik çalışmalarınız da hız ve kolaylıklık sağlamaktadır.

Araç Çubukları

İhtiyacınıza bağlı olarak araç çubuklarının görüntülenmesini veya gizlenmesini sağlayabilirsiniz. Görüntülemek veya gizlemek için, Görünüm-->Araç Çubukları menüsünü kullanabilirsiniz.

Ayrıca bu araç çubuklarında görünmesini istediğiniz simgeleri belirleyebilirsiniz. Bazı araç çubuklarında simgeler varsayılan olarak gösterilmezler. Ancak onları sizler seçip görüntülenmesini veya gizlenmesini sağlayabilirsiniz. Bunu yapmak için, araç çubuklarının sonunda bulunan özelleştir butonuna basarak açılan menüden Görünür Düğmeler seçeneğinde tüm simgelerin listesini görebilirsiniz. Bu listede yer alan simgelere tıklayarak gizleme veya görüntüleme işlemlerini kolayca yapabilirsiniz. Özelleştir butonu aşağıda kırmızı ile işaretlenmiştir.


Draw11.png



Uygulamalarınızda en çok ihtiyaç duyacağınız Çizim araç çubuğudur.


Draw5.png


  • Seçim : Dokümanınızda bulunan objeleri seçmenizi sağlar.
  • Çizgi : Çizgi çizmenizi sağlar.
  • Sonu Oklu Çizgi : Sonu okla biten çizgi çizmenizi sağlar.
  • Dikdörtgen : Dikdörtgen çizmenizi sağlar.
  • Elips : Elips çizmenizi sağlar.
  • Metin : Metin kutusu eklemenizi sağlar.
  • Eğri : Açılır menüsünden istediğiniz şekli seçerek dinamik çizgiler oluşturabilirsiniz.
  • Bağlayıcı : Objeleri birbirine bağlamak için araçlar sunar.
  • Çizgiler ve Oklar : Çizgi ve ok çizimleri için yardımcı araçları sunar.
  • Temel Şekiller : Temel geometrik çizimlerini (kare, dikdörtgen, daire, üçgen vb.) barındırır.
  • Simge Şekiller : Çeşitli konularda simgeler mevcuttur.
  • Kalın Oklar : Çeşitli oklar çizmenizi sağlar.
  • Akış Çizelgeleri : Akış diyagramları veya organizasyon şemaları için çeşitli şekiller.
  • Belirtme Çizgisi : Çeşitli belirtme çizgilerini barındırır.
  • Yıldızlar : Çeşitli köşe sayılarında yıldız objeleri sunar.
  • Noktalar : Çizim üzerindeki noktaları düzenler.
  • Yapışma Noktaları : Çizim üzerindeki yapışma noktaları düzenler.
  • Yazı Sanatı Galerisi : Çeşitli yazı biçimleri ekler.
  • Dosyadan : Geçerli belgenize dosyadan resim ekler.
  • Galeri : Uygulamanın mevcut çizimlerini ekler.
  • Efektler : Seçilen objelerin yönelim ve doldurma işlemlerini gerçekleştirir.
  • Hizalama : Seçilen objelerin hizalanmasını sağlar.
  • Sıralama : Seçilen objelerin üst veya alt yerleşimlerini belirler.
  • Çıkarma Açık/Kapalı : Seçilmiş nesne için 3B efektleri açıp kapatır.

Durum Çubuğu

Durum çubuğu, ekranın altında yer alır ve kullanıcıya çeşitli bilgiler verir. Durum çubuğunda, yükseklik, genişlik, yaklaşma oranı vb. bilgiler yer alır.

Basit Çizim Oluşturma

Buraya kadar kısaca OpenOffice.org Çizim hakkında ve arayüzünden bahsettik. Şimdi ise bu yazdığımız özellikleri kullanarak bir örnek yapmaya çalışacağız. İlk örnek olarak birlikte 3D kutu nasıl oluşturulur görelim. İşlem adımları;

  • İlk olarak çalışma sayfamıza çizim araç çubuğumuzda bulunan Temel Şekiller simgesine tıklıyoruz.
  • Karşınıza bu simgede bulunan tüm semboller listelenecektir. Bu sembollerden karesel olanı seçip çalışma sayfamıza gelişi güzel bir kutu çiziyoruz. Örneğimizde kutumuz aşağıdaki gibi görünecektir.


Draw6.png


  • Çizmiş olduğumuz bu kutu şimdilik 2D boyutundadır. Şeklimizi 3D boyutuna dönüştürmek için, sembolümüzü fare yardımıyla seçiyoruz.
  • Farenin sağ tuşuna basarak açılan menüden Dönüştür-->3B Cisme yolunu takip ettiğimizde cismimizin 3D olarak görüntülendiğini göreceğiz. Bu işlemden sonra, örneğimizde kutumuz aşağıdaki gibi görünecektir.


Draw7.png


  • Bu işlemimizi gerçekleştirdikten sonra kutumuzun boyut ve görünümünü ayarlayalım. Bu ayarlar için ilk önce cismimizi seçip farenin sağ tuşu yardımı ile açılan menüden 3B Efektler sekmesine tıklıyoruz. Karşımıza aşağıdaki gibi bir diyalog kutusu gelecektir.


Draw8.png


  • Bu diyalog kutusundaki ayarlarımızı şu şekilde ayarlayacağız. Ayarladıktan sonra uygula butonuna basmayı unutmayınız.

İlk Sekme;

Yuvarlanmış Köşeler : 0%

Derinlik : 5,00 cm

İkinci Sekme;

Kip : Phong

  • Bu ayarlardan sonra kutu görünümü aşağıdaki gibi olacaktır.


Draw9.png


  • Son olarak kutumuza güzel bir ahşap döşemesi yapalım. Bu işlem için, cismimizi seçip farenin sağ tuşu yardımı ile açılan menüden Alan sekmesine tıklıyoruz ve Bit Eşlem sekmesine geçiyoruz.
  • Burada örnek olması açısından İnternet'ten bulmuş olduğum bir ahşap resmimi kullandım. Sizler farklı resimde kullanabilirsiniz. Resmimizi içe aktar butonu yardımı ile uygulamamıza ekliyoruz.
  • Bize kaydedeceğimiz ismi soracaktır. Uygun bir isim yazarak kaydediyoruz ve tamam düğmesi yardımı ile cismimize uyguluyoruz.
  • Kutumuzun kenarlarını çizmek için cismimizi seçip farenin sağ tuşu yardımı ile açılan menüden Çizgi sekmesine tıklıyoruz.
  • Bu diyalog kutusundaki ayarlarımız ise aşağıdaki gibi olacaktır.

Biçem : Sürekli.

Renk : Gri 60%

Genişlik : 10%

Köşe Biçemi : Köşeli.

  • Kutumuzun son hali aşağıdaki gibi görünecektir. Eğer siz isterseniz ayarlarla oynayarak başka şekiller de ortaya çıkarabilirsiniz.


Draw10.png


Çizimi Kaydetmek ve Dışarı Aktarmak

Çizimlerimizi bitirdikten sonra Dosya-->Kaydet yolunu takip ederek veya Ctrl+S kısayol tuşu ile grafiğimizi kaydedebiliriz. Eğer dosyamızı dışarı aktarmak istiyorsak Dosya-->Dışarı Aktar yolunu takip ederek dosyamızı pdf formatında hızlı bir şekilde kaydedebiliriz.

OpenOffice.org 3.1 İle Gelen Yenilikler

  • Kenar yumuşatma : Çizimlerde özellikle çember, eğri ve çapraz çizgilerin kırılmaya uğramadan daha düzgün görünmesini sağlar.
  • Geliştirilmiş resim kesme.
  • Geliştirilmiş pdf dışa aktarma.
  • Çizim programı içerisinde geliştirilmiş sayfa boyutu (300 cm * 300 cm).
  • Yarı saydam sürükleme.
  • Üst üste gelen 2 objeyi birbirinden çıkartma.


Temel Draw Ayarları

Bu döküman Windows XP altında çalışan OpenOffice.org nin aşağıda görünen Hakkında ekranına sahip sürümü ile oluşturulmuştur. Çok eski veya Çok daha ileri sürümlerde farklılıklar oluşabileceği unutulmamalıdır.


Draw hakkında.JPG



OpenOffice.org ayarlarına Araçlar menüsünde bulunan Seçeneler... ile ulaşılabilir.


Draw secenekler ekranı.JPG



Gelen ekranda Openoffice.org Draw sekmesinde bulunan alt sekmeler ile genel Draw ayarlarını yapmak mümkündür. Bu aşamada tüm ayarlar anlatılmayıp sık kullanılan ve başlangıç düzeyinde gerekli olacak ayarlar anlatılmıştır.

Openoffice.org Draw --- Genel

Arkaplan için önbellek kullan kutusu arkaplanın değiştirilebilmesinde gelişmiş özellikler kullanılmasını sağlar. Özellikle taranarak bilgisayar ortamına aktarılmış bir resmin referans alınarak çizim yapılması gibi durumlarda gereklidir. Seçili olması tavsiye edilir. Ölçü birimi açılır penceredir ve çiziminizin uzunluk ve uzunluğa bağlı birimini belirler. Genelde santimetre veya Milimetre olarak kullanılır.Başlangıç düzeyindeki kullanıcılar için Santimetre olarak ayarlanabilir. Bu noktada ölçü ve ölçü birimleri hakkında genel bir bilgi verilmesi gerekir. Ölçü birimi tüm proje için aynıdır. Başka değişle her nesne için ayrı ayrı tanımlanamaz. Openoffice.org tarafından yapılan otomatik ölçülendirmelerde santimetre için cm gibi kısaltmalar kullanılabilir. Bu ayarı varolan bir proje üzerinde değiştirdiğinizde projede yeni ayara uygun değişiklikler otomatik olarak yapılabilir. Çizim ölçeği açılır penceredir ve çizimde kullanılacak ölçek bilgisini saklar. Sıklıkla kullanılan oranlar önceden tanımlanmıştır. Bu durum misal 1:23 gibi bir ölçek kullanamayacağınız anlamına gelsede sorun teşkil etmez zira kullanma ihtimaliniz olan, standart denilebilecek oranlar mevcuttur. Openoffice.org de çizim ölçeği hakkında bir bilgi vermek gerekir zira bilinen çizim uygulamalarının çok azında bu şekilde ölçek atanabilmektedir. Varolan bir çizimde Çizim ölçeği değişikliği yaparsanız varolan çizimlerin boyutunda değişiklik olmaz. 1:1 ölçeği birebir olarakta bilinen gerçek ile çizimin aynı boyutta olduğu anlamına gelir. : ile ayrılmış şekilde yazılan sayılardan soldaki çizimdeki ölçüyü, sağdaki ise gerçek ölçüyü tanımlar. 1:20 gibi bir oran gerçekte 40 santimetre olan uzunluğun kağıt üzerinde 2 cm olduğunu belirtir.

Openoffice.org Draw--- Görünüm

Cetvelleri göster kutusu çizim alanının kenarında kalan ekran bölümlerinde cetvel görünmesi ile ilgili ayarını sağlar. Tavsiye edilen seçili olmasıdır. Taşıma sırasında klavuzları göster kutusu varolan bir nesnenin taşınması durumunda ekranda yatay ve dikey olarak çizgiler belirmesini ayarlamanızı sağlar. Tavsiye edilen seçili olmasıdır.

Openoffice.org Draw --- Izgara

Buradaki ayarları anlatmadan önce ızgara tanımını açmak gerekir. Izgara yada bilinen adı ile grid kavramı gerçek çizimlerde beyaz kağıt altına çizgili kağıt koyarak beyaz kağıtta görünen çizgileri referans alıp düzgün yazı yazmaya veya milimetrik kağıt kullanmaya benzer. İsterseniz sadece ekranda görünen ve çiziminizi kolaylaştıran ama yazıcıya aktarılmayan sanal noktalardır. Izgaralar estetik adına ölçülendirmeden taviz verilebilecek çizim veya çizim kısımlarında kullanılır. Özellikle Elektrik veya makine iş disiplini gibi dallardaki profesyonel çizimlerde ızgara kullanımı neredeyse standart olmuştur. Izgaraya uydur kutusu çizimlerinizin mutlaka ızgara noktalarına göre oluşturulmasını ve taşınmasını sağlar. Seçili olması tavsiye edilir. Izgara çizgilerini göster kutusu ızgara noktalarının ekranda gösterilmesini sağlar. Izgara noktaları ekranda görünür ama yazıcıda görünmez. Çözünürlük Yatay ve Çözünürlük Dikey alanları ızgara noktaları arasındaki mesafeyi belirler. Uzunluk ölçü birimine sahiptir. 1 cm gibi değerler alabilir. Standart diyebileceğimiz bir değere sahip değildir. Çizenin alışkanlıkları, çizim konusu işin hassasiyeti gibi değişkenlere bağlı olarak atanabilir. Tüm proje için aynıdır. Çizim olan projede değişiklik yapılırsa mevcut çizimlerde değişiklik olmaz. Benim kullandığım değer 0,2 cm dir. Altbölme Yatay ve Altbölme Dikey alanları her ızgara alanının kaça bölüneceğini belirler. Çözünürlük Yatay ve Çözünürlük Dikey aksine uzunluk ölçüsü birimi yoktur. Yine Çözünürlük Yatay ve Çözünürlük Dikey de olduğu gibi standart diyebileceğimiz bir değeri yoktur. Ben 2 olarak kullanıyorum. Izgaralar arası mesafe çözünürlük / Altbölme olarak belirlenir. Çözünürlük 0,2 cm, Altbölme 2 ise ızgaralar arası mesafe 0,2/2=0,1 cm dir.

Openoffice.Draw kullanırken değiştirebileceğiniz başka ayarlarda mevcuttur.

Openoffice.org --- Kullanıcı verisi

Bu alandaki bilgilerin oluşturulan veya ilgili alanlarında değişiklik yapılan her yeni belgeye ekleneceğini unutmayın. Ayrıca Pdf dosya oluştururken de bu alandaki bilgilerin bir kısmı kullanılır.

Openoffice.org --- Bellek

Buradaki ayarlar tüm OpenOffice.org için geçerlidir. RAM bellek için geçerli ayarları saklar. Tavsiye edilen yüksek miktarlarda ayarlamaktır. Kendi kullandığım ayarlar şu şekildedir.


Draw Bellek ayari.JPG



Openoffice.org --- Görünüş

OpenOffice.org uygulamasının kullanacağı renk düzenini buradan ayarlayabilir, renk şablonu hazırlayabilirsiniz. OpenOffice Draw ile ilgili en önemli ayar Izgara rengidir. Izgara rengi olarak kullanmayacağınız renklerden birini ayarlamanızı tavsiye ederim zira düşük yaklaştırma oranlarında ızgara ile nesne renkleri karışabilir.



Draw gorunus ayari.JPG


Eskiwiki.png This page is imported from Eskiwiki (previously Wiki.OpenOffice.org.tr) The whole page content and all revisions are licensed under:
24px24px This work is licensed under the Attribution NonCommercial 3.0 Unported License